IBProvider v5.30. DECFLOAT and improved connection pool [FB4]

Hello Everyone.

In the current release, we have continued expanding the support of Firebird v4.

https://www.ibprovider.com/eng/news/n_230620__fb4_step2.html

New features

  • The full support of DECFLOAT(16) and DECFLOAT(34) has been implemented
  • The new version of IBProvider supports the ICU v63 from FB4 kit
  • Using «ALTER SESSION RESET» for resetting a connection before reusing (see this new example)

Kind Regards and Good Luck! IBProvider Team.

Jaybird 5.0.2 released

We are happy to announce the release of Jaybird 5.0.2.

The following has been fixed since Jaybird 5.0.1:

  • Fixed: Reconnect transaction with a transaction id exceeding 0x7FFF_FFFF did not work (jaybird#734)
  • New feature: add connection property parallelWorkers to set Firebird 5.0 isc_dpb_parallel_workers (jaybird#737)
  • New feature: add MaintenanceManager.upgradeOds() for the Firebird 5.0 gfix/service repair action to perform a minor ODS upgrade of a database (jaybird#738)
  • New feature: add parallel workers support for BackupManager (jaybird#739)
  • New feature: add parallel workers support for sweep in MaintenanceManager (jaybird#740)
  • Fixed: DatabaseConnectionProperties.setServerBatchBufferSize(int) ignored provided value and always set default (0, or “use server-side maximum”) (jaybird#741)
  • New feature: add MaintenanceManager.fixIcu() for the Firebird 3.0 gfix/service repair action “ICU” to update or rebuild collations and indexes when the ICU version changed (jaybird#744)
  • Fixed: The first call to getTableStatistics() of a FBTableStatisticsManager instance returned only a few or even no tables; if no tables were returned, subsequent calls would also return no tables (jaybird#747)

Jaybird 5 supports Firebird 2.5 and higher, on Java 8, 11, 17 and 20 (support for Java 11 and higher using the Java 11 version of the driver).

See also:

IBProvider v5.29. The initial support of FB4

Hello All 🙂

The implementation of FB4 support requires time. That is why we decided to split this process into parts and make intermediate releases. It will allow you to begin using IBProvider with FB4 right now.

https://www.ibprovider.com/eng/news/n_230522__fb4_step1.html

The current support of FB4

  • You can work with FB4 through fbclient.dll
  • You can work with FB4 through a built-in client (dbclient_type=fb.direct). The 13th protocol will be used
  • The long name of database objects are supported
  • All the FB4 datatypes (including new datatypes: INT128, DECFLOAT, time/date with a time zone) are supported at the metadata layer
  • The full support of INT128 and NUMERIC on base INT128 was implemented
  • New initialization properties were added — int128_rulesnumeric_i16_rules

Lots of functional and load tests were made with using FB v4.0.3.2937.

For mission-critical, multi-threaded and 24/7 applications, we highly recommend using the built-in client.

IBProvider Free does not support FB4.

Additional changes

  • The support of DBTYPE_TIMESTAMPOFFSET was added
  • The transformation between {DBTIME, DBTIME2} and {DATE, DBDATE, DBTIMESTAMP, FILETIME} was deleted
  • The transformation of NUMERIC into VARIANT was improved
  • The procession of charset names was corrected

With best regards, IBProvider Team.

Database Workbench 6.2.0 released

Upscene Productions is proud to announce the availability of the next release of the popular multi-DBMS development tool:

” Database Workbench 6.2.0″

This release brings support for the latest PostgreSQL versions, recognizes Firebird 5 beta, and brings new features in general.

One of the major changes is the new object selection box in the Object Editors: much faster on a large number of objects and it now includes a filter for easier usage.

Database Workbench 6 comes in 3 different editions with different pricing models, there’s always a version that suits you!

The release of IBProvider v5.28

Hello Everyone!

We are pleased to present this new release of our flagship product. During its development, a number of old problems were identified and solved. Also the internal structure was improved for the next stage of development.

https://www.ibprovider.com/eng/news/n_230424.html

List of changes

  • The keyword list of FB v2.5.9 was corrected.
  • The keyword list of FB v3.0.4+ was corrected.
  • The definition of TIMESTAMP, TIME and DATE in PROVIDER_TYPES was corrected.
  • [DirectFB] The support of protocols v10-v12 was corrected. It solves problems with FB3.
  • [DirectFB] The support of protocol v13 was improved.
  • [ISC API] The protection from negative length of CHAR/VARCHAR datatypes was added.
  • The new initialization property «force_nulls» was added for conducting low-level tests.
  • Lots of internal changes and improvements were made.

Testing

  • Our primary test server for load tests is FB v3.11.

The current plans

  • The primary direction of our work is the implementation of FB4 support.

With best regards, IBProvider Team.

Curso: Backups no Firebird (PT-BR)

This is only for Portuguese speakers.

Está cansado de lidar com a constante preocupação de perder informações importantes do seu banco de dados Firebird? Quer ter a certeza de que seus dados estão protegidos e sempre disponíveis, mesmo em situações de emergência? Então você precisa conhecer esse curso especializado em backups de banco de dados Firebird!

Você aprenderá técnicas avançadas e muitas vezes desconhecidas para fazer backups eficientes e confiáveis. Descubra também como fazer backup/restore em um único passo, sem precisar criar arquivos intermediários, economizando tempo, espaço em disco e simplificando o processo.

Saiba também como usar o gbak gerando como resultado final um backup já compactado com o 7zip, otimizando espaço em disco! Você também aprenderá sobre backups incrementais, mais rápidos e que armazenam apenas dos dados que foram adicionados ou alterados desde o último nível de backup, deixando o processo mais eficiente e possibilitando a realização de backups mais frequentes.

Apenas durante o lançamento, até o dia 24/fevereiro, o curso estará sendo vendido de R$ 397 por R$ 250 através do link tinyurl.com/uyuupcez. Todos compradores receberão também gratuitamente meu eBook Guia de Migração para o Firebird 3!

Não perca mais tempo e garanta agora seu acesso a esse curso exclusivo! Proteja seus dados e tenha a certeza de que eles estão sempre seguros. Torne-se um expert em backups de banco de dados Firebird!

A venda e a entrega estão sendo feitas via plataforma Eduzz, e você pode pagar com cartão, pix ou boleto bancário.

Jaybird 5.0.1 and 4.0.9 released

We are happy to announce the release of Jaybird 5.0.1 and Jaybird 4.0.9.

Jaybird 5.0.1

The following has been fixed since Jaybird 5.0.0:

  • Fixed: Executing DML with a RETURNING clause containing a blob column would return the blob-id instead of the blob value (jaybird#728)
  • Fixed: CallableStatement.getString and CallableStatement.getObject would incorrectly trim string values (jaybird#729)
  • Fixed: ResultSetMetaData.getPrecision(int) of a connectionless result set could throw a NullPointerException if the column was of type FLOAT or DOUBLE PRECISION (jaybird#730)

Jaybird 5 supports Firebird 2.5 and higher, on Java 8, 11, 17 and 19 (support for Java 11 and higher using the Java 11 version of the driver).

See also:

Jaybird 4.0.9

The following has been fixed since Jaybird 4.0.8:

  • Fixed: Some methods of FBClob threw NullPointerException when attempting to use after implicit or explicit free() (jaybird#719)
  • Improvement: If the default JVM time zone is a GMT offset, e.g. GMT-08:00, configure sessionTimeZone with offset only, e.g. -08:00 (jaybird#720)
  • Fixed: Executing DML with a RETURNING clause containing a blob column would return the blob-id instead of the blob value (jaybird#728)
  • Fixed: CallableStatement.getString would incorrectly trim string values (jaybird#729)
  • Fixed: ResultSetMetaData.getPrecision(int) of a connectionless result set could throw a NullPointerException if the column was of type FLOAT or DOUBLE PRECISION (jaybird#730)

Jaybird 4 supports Firebird 2.5 and higher, on Java 7, 8, 11, 17 and 19 (support for Java 11 and higher using the Java 11 version of the driver).

See also:

IBProvider News

Hello Everyone.

We have a couple of news for you.

1. We have just released the new set of our components where is provided a new solution to using IBProvider without registration in Windows:

  • IBProvider v5.27
  • LCPI OLE DB Services v1.22
  • LCPI ADO.NET Data provider for OLE DB v1.26

2. We released Free IBProvider x64.

You can get more information about these things at our web site.

https://www.ibprovider.com/eng/news/n_230125.html

With Best Regards, IBProvider Team.

Upscene releases new version of test data generator

Upscene Productions is happy to announce the next version of their test data generator tool:

“Advanced Data Generator 4.1.0”

A fast test-data generator tool that comes with a library of real-life data, can generate data to your database,
script or data files, many filling options, templates and much more.

1 2 3 4 5 146