Fix for Meltdown and Spectre will affect your server performance!

Microsoft, Apple and several Linux distros started to distribute patches to try to fix the recent security flaws found in Intel, AMD and ARM CPUs, in almost every CPU released in the last 20 years. The security flaws are known as Meltdown (affects Intel) and Spectre (affects Intel, AMD and some ARM processors).

The flaw allow softwares to access protected memory areas that should be accessed only by the Operating System kernel, and get sensitive data, like passwords, etc.

There are two problems with the fixes:

  1. They do not fix 100% of the problem, since it is related on how the CPUs were designed. So far, there is no 100% solution for the problem, and probably it will never exists.
  2. They impact badly in performance.

In a recent post to firebird-devel list, an user reported that the performance of the Firebird server dropped ~30% after he upgraded its Linux kernel to a version that “fix” those security flaws.

General reports over the internet shows that the most affected areas of the system are CPU, RAM and Disk, so any software that makes intensive use of some of those areas will probably have its performance significantly degraded.

Just to be clear: this performance loss doesn’t affect only Firebird, but any software!

1 Star2 Stars3 Stars4 Stars5 Stars (3 votes, average: 5.00 out of 5)
Loading...

8 comments

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.