Firebird 3.0.1 is packaged in Debian testing and in unstable

For Ubuntu we recommend Firebird 3.0 ppa where package is imported directly from Debian repository

Ubuntu Supported Versions  : Ubuntu 16.10 (Yakkety) , 16.04 (Xenial)  and 14.04 (Trusty)

Firebird 3.0 popcon graph for Debian is here

ps: Firebird 2.5 is removed from Debian archive (replaced by Firebird 3.0 package in Debian unstable and testing)