[WARNING] Intel Skylake/Kaby Lake processors: broken hyper-threading

Here is the Warning from Debian Developers :

This warning advisory is relevant for users of systems with the Intel
processors code-named “Skylake” and “Kaby Lake”. These are: the 6th and
7th generation Intel Core processors (desktop, embedded, mobile and
HEDT), their related server processors (such as Xeon v5 and Xeon v6), as
well as select Intel Pentium processor models.

TL;DR: unfixed Skylake and Kaby Lake processors could, in some
situations, dangerously misbehave when hyper-threading is enabled.
Disable hyper-threading immediately in BIOS/UEFI to work around the
problem. Read this advisory for instructions about an Intel-provided
fix.

And the Related Reddit Thread

1 Star2 Stars3 Stars4 Stars5 Stars (2 votes, average: 3.00 out of 5)
Loading...

New DDEX provider for work with Firebird and InterBase in Visual Studio 2017

Release of “LCPI ADO.NET data provider for OLE DB” v1.1 includes the new DDEX provider (v2) for Visual Studio 2017.

http://www.ibprovider.com/eng/news/n_170622.html

Main features of new DDEX provider

  • Based on a new object model (v2), like standard DDEX providers for MSSQL and Oracle
  • Packed in VSIX installer

See the short instruction for installation and configuration of DDEX provider in VS2017.

1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
Loading...

Database .NET 22.2 and dbMigration .NET 5.8 released!

Database .NET 22.2 is an innovative, powerful and intuitive multiple database management tool. (Full support for Firebird 1.5~4.0+)
http://fishcodelib.com/Database.htm (Change Log 2017/06/19)

dbMigration .NET 5.8 is a simple, easy and intuitive multiple database migration and data synchronization tool, With it you can easily migrate schema and data to Firebird and vice versa.
http://fishcodelib.com/DBMigration.htm (Change Log 2017/06/19)


1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
Loading...

HQbird 2017R2

HQbird 2017R2 is a major upgrade of advanced Firebird distributive (versions 2.5 and 3.0) with high-availability, replication, optimization, monitoring and recovery tools. Please upgrade the previous version of HQbird with 2017R2 (this upgrade is free for all users of HQbird).

This release includes a lot of improvements in replication, monitoring, and optimization, as well as many bugfixes. Windows installer now supports an automatic upgrade of the existing HQbird installation, Linux support for auto-upgrade will be released later.

The main goal of HQbird 2017R2 is to provide administrators and developers of big Firebird databases with effective management, maintenance, recovery, and optimization tools, in order to keep databases always healthy and available.

More details about HQbird: https://ib-aid.com/hqbird

1 Star2 Stars3 Stars4 Stars5 Stars (1 votes, average: 5.00 out of 5)
Loading...

Jaybird 3.0.1 released

The Firebird JDBC team is happy to announce the release of Jaybird 3.0.1.

Jaybird 3.0.1 contains the following fixes and changes:

  • Fixed: FBTraceManager.loadConfigurationFromFile strips line breaks (JDBC-493)
  • Fixed: FBDatabaseMetaData.getTables does not list tables where rdb$relation_type is null (JDBC-494)
  • Improvement: Character sets are now initialized lazily (JDBC-495)
  • Fixed: Memory leak caused by retaining blob handles until connection close (JDBC-497)

See the Jaybird 3.0.1 release notes for more information. Jaybird 3.0.1 can be downloaded from the JDBC Driver page.

1 Star2 Stars3 Stars4 Stars5 Stars (2 votes, average: 5.00 out of 5)
Loading...

The pain of no documentation

Free software is suffering because coders don’t know how to write documentation

Interesting article (read it here). As much important as the “source code documentation” is the documentation for the users. Firebird suffered from the lack of official documentation for a long time. This is being fixed, and you can help right now, contributing to the newest doc crowdfunding from the Project.

1 Star2 Stars3 Stars4 Stars5 Stars (1 votes, average: 5.00 out of 5)
Loading...