The Perfect Database Server: Firebird 2.5.4 And FreeBSD 10.2

Here is the guide on installing Firebird 2.5.4 from FreeBSD 10.2 Ports and creating your first test database; also we show you how to install Flamerobin GUI (administration tool) and the PHP driver for it. This was tested on fresh FreeBSD 10.2 x64.

Download a compressed snapshot of the Ports Collection into /var/db/portsnap.

portsnap fetch

Or update it. If you are running Portsnap for the first time, extract the snapshot into /usr/ports:

portsnap extract

If you already have a populated /usr/ports directory and you are just updating, run the following command instead:

portsnap update

Enter firebird server ports directory:

cd /usr/ports/databases/firebird25-server

Compile and install firebird server:

make -DPACKAGE_BUILDING
make install

Enable it by adding

firebird_enable="YES"

in /etc/rc.conf.

Start it with:

/usr/local/etc/rc.d/firebird start

logs and security2.fdb seems to be in /var/db/firebird.

/usr/local/bin/isql-fb

To create a new database:

SQL> create database “tmp/first_database.fdb”;
SQL> connect “/tmp/first_database.fdb” ;

Commit current transaction (y/n)? <– y
Committing.
Database: “/tmp/first_database.fdb”
SQL>

If you want to create a simple table then insert 1-2 rows and select from it; here is one example:

SQL> CREATE TABLE TEST (ID INT NOT NULL PRIMARY KEY, NAME VARCHAR(20));
SQL> show tables;

TEST
SQL> INSERT INTO TEST VALUES (1, ‘John’);
SQL> INSERT INTO TEST VALUES (2, ‘Joe’);
SQL> select * from test;
ID NAME
============ ====================
1 John
2 Joe

To quit the isql-fb console, type quit:

SQL> quit
CON>;

For a good open source GUI admin tool you might check the flamerobin administration tool included in ports repository; it can be installed by a simple:

cd /usr/ports/databases/flamerobin/ && make install clean

Or if you don’t want to wait use pkg-add

pkg-add -r flamerobin

To use firebird with php, you will need the php5 driver:

cd /usr/ports/databases/php5-interbase/ && make install clean

You can choose to compile php with apache support (I have chosen cli, cgi , and apache support); check it if is enabled with:

/usr/local/bin/php -m

Or if you don’t want to wait compile all the php use pkg-add

pkg-add -r php5-interbase

 

Updated Russian documentation for Firebird 2.5 and beta Reference documentation for Firebird 3.0

Post by AlexeyKovyazin on habrahabr :

Many readers  interested Firebird, may know that last year we saw releasead documentation on Firebird SQL language in Russian version 2.5.Creating documentation is sponsored the Moscow Stock Exchange as a platinum sponsor and one of the largest users of Firebird in Russia, and the company IBSurgeon / IBase, representing Firebird in Russia.

But this work is not over:

We began translating and proofreading of documents in English, German and Portuguese. Helen Borrie, the author of the famous Firebird book , is the editor of the English edition. We expect to publish the English version in October this year, Portuguese and German versions – early next year. At the same time in the Russian original documentation of 2.5 there were made ​​over 1,000 corrections and additions (thanks to Denis Simonov, editor of the Russian version), as well as we conducted a lot of work on Reference documentation for version 3.0. We recommend to download an updated version of the Firebird 2.5 documentation in Russian and get acquainted with the beta version 3.0 documentation for Firebird: www.ib-aid.com/download/firebirdlangref30rus.pdf .If you find an error or typo in the documentation, do not hesitate and send bug-report directly to the Tracker for Russian developer documentation: www.assembla. com / spaces / firebird-russian-documentation / . In the Files group you can download the latest version of the documentation.

Free seminar on large Firebird databases will be held on October 21, 2015 in Moscow


Firebird Project and the company IBSurgeon (IBase.ru) announced that Firebird SQL administrators and developers are invited to a free seminar on working with Big Firebird Databases. The workshop will be held  on October 21, 2015 in Moscow. To participate in the seminar is by invitation only – see Below. Brief seminar topics:

  1. Backup of large databases.
  2. Optimize performance in large databases.
  3. An example of analyzing the structure of the production database of 1 terabyte in size.
  4. Replication.
  5. Scaling, clustering.

Details here: ibase.ru/firebirdtour2016.html

Due to the limited places to visit you must get an invitation to the seminar. To receive an invitation, write to support@ibase.ru marked “Seminar BBD” and brief information about your company and the database (size, number of users, application area). If your database is larger than 500GB, you’ll definitely get a invitation if less, depending on availability.

Firebird package updated in Debian : 2.5.4.26856.ds4-2

This version will make the build reproducible.

The reproducible builds initiative aims to enable anyone to reproduce bit by bit identical binary packages from a given source, thus enabling anyone to independently verify that a binary matches the source code from which it was said it was derived. For example, this allow the users of Debian to rebuild packages and obtain exactly identical packages to the ones provided by the Debian repositories.

Prune tool sets the creation stamp in the database header to a fixed value (taken from the last changelog stanza) and
prunes unused space on index/data pages of shipped databases

New Firebird dbExpress drivers released

banner_dbx

Following the updated release of IBDAC (Delphi data access components for Firebird) Devart released a huge update of it’s dbExpress drivers. Among them you can find updated dbExpress driver for Firebird/Interbase.

Among many improvements and bug fixes those drivers received RAD Studio 10 support and now the trial limitation by 6 columns is removed from the Trial version for Win64 and it becomes a fully-functional Professional Edition.

You can already download new updated dbExpress driver for Firebird now – https://www.devart.com/dbx/interbase/download.html

 

Released a new version of Firebird Delphi data access components (IBDAC)

banner_dac

Devart company released a huge update of all its Delphi data access components including Firebird/Interbase data access components (IBDAC).

IBDAC 5.6 main updates/fixes are:

  • RAD Studio 10 Seattle is supported
  • INSERT, UPDATE and DELETE batch operations are supported
  • Now Trial for Win64 is a fully functional Professional Edition
  • Now at automatic refresh of Detail dataset the OnBeforeOpen event is not called
  • Generating conditions for filtration when using similar field names and aliases in TCRDBGrid is fixed
  • SQLMonitor behavior on using similar objects is fixed
  • Bug with endless reconnection in assigned connection is fixed
  • Bug with editing Blob and Memo fields used in local filter is fixed
  • Bug when working with databases having charset NONE is fixed

You can already download new IBDAC 5.6 now and use it in your projects.

1 2